本站不兼容 8 以前的版本的 Interner Explorer 浏览器(或基于这些版本的 IE 的其他浏览器),并且页面样式不完全兼容 IE 8,我们建议你升级至 IE 9 或改用其他非 IE 浏览器

Mozest™

  • 正在加载用户菜单…

开放、分享、互助

转播到腾讯微博
返回列表 回复 发帖

[交流] fireIE 0.4.3b 依然不支持e10s

我本来以为是0.4.2正式版不支持,换了一个开发版,结果还是不支持……虽然说大部分网站都没影响,但是少数网站还是没有办法只能在IE模式下用,这个暂时不兼容的话就只能暂时IE顶一阵了,感觉在e10s下,所有以overlay方式开发的扩展以及UC脚本中如果有读取页面信息的代码就很容易挂掉……不知道是不是这方面改动了……
报错全部在objectTabs.js,全部原因是unsafe CPOW usage
这个很难搞。。得动大刀子,估计短时间内支持不了。
3# patwonder
无妨,反正照现在的进度来看就算到了40版e10s都不会进release,我自己应该也一段时间不会再开了(不然连b站新浪源视频都看不了),这工作还有很多个版本的时间,实在不行我直接UC脚本调IE出来也行的
4# Achemer

e10s分支上目前的版本基本兼容多进程了,只有一些小问题,有兴趣的话可以自行编译:
https://github.com/yxl/Fire-IE/tree/e10s

跟踪issue:https://github.com/yxl/Fire-IE/issues/128
0.4.5b版本已发布,支持e10s Nightly。下载地址:http://yxl.github.io/Fire-IE/fireie-0.4.5b-unified.xpi
6# patwonder
已经更新了,不过在e10s上性能还是不太好,估计e10s本身代码质量有问题
7# Achemer

可能是因为 0.4.5b 默认开启了 OOPP,增加了进程间通讯开销。

你可以试试把 dom.ipc.plugins.enabled.npfireie32.dll 改成 false,看性能是否有所改善。