本站不兼容 8 以前的版本的 Interner Explorer 浏览器(或基于这些版本的 IE 的其他浏览器),并且页面样式不完全兼容 IE 8,我们建议你升级至 IE 9 或改用其他非 IE 浏览器

Mozest™

  • 正在加载用户菜单…

开放、分享、互助

大家国庆快乐!

大家的walk-input.js还好用吗
我的又不行了,更新了一下还是不起作用,按 alt+i 就进隐私模式,进的过程中还经常卡死。。。

咋回事呢
1651# mrfox

试试附件里这个~
附件: 您所在的用户组无法下载或查看附件
听老人说,今生做千件好事,来世方能讨生为猫。
本帖最后由 mrfox 于 2015-10-1 23:45 编辑

1652# harnack

谢谢h大,替换了还是不行,我觉得我已经掉进黑洞了(一度以为是键盘坏了,换了一个也是一样。。。),FF进入隐私浏览的快捷键明明是ctrl shift p,怎么可能由alt i 触发呢,百思不得其姐~~

update: 折腾了半天,后来居然就好了!!不知道为什么,也没改啥。。。

感谢H大!!!

另外我看(虽然看不懂)walk-input.js代码里有 <M-i>,这里的M代表的是什么,是不是也是个快捷键
本帖最后由 harnack 于 2015-10-2 00:04 编辑

1653# mrfox

M 应该是指 Mac 键盘中的那个 command 键吧,纯属猜测,没用过 Mac ……
听老人说,今生做千件好事,来世方能讨生为猫。
每次刚启动火狐,不能 jk 滚动页面,提示一个错误
resource://dactyl/buffer.jsm: 1680: TypeError: options is undefined

方向键 up/down 没有问题
进入一次命令行模式(:),或者手动开启一个新页面(包括about:blank),一切就恢复正常

不知道你们有没有这个问题,求解决办法
1651# mrfox

试试附件里这个~
harnack 发表于 2015-10-1 22:33
猫大,你这些可用的插件都是哪里找来的,我的很多插件都过期了,多半就放弃使用了
那个“options is undefined”存在至少一两年了,一直都没修复……解决办法估计只能修改源代码,可以试试将 buffer.jsm 第1678行的
  1. let { options } = overlay.activeModules;
复制代码
改成
  1. let doc = node.ownerDocument || node.document || node;
  2. let { buffer, marks, options } = util.topWindow(doc.defaultView).dactyl.modules;
复制代码
看行不行。

我也不知道到哪去找插件,网上能找到的很多都失效了,前面那个 walk-input.js 是我自己修改过的……
听老人说,今生做千件好事,来世方能讨生为猫。
那个“options is undefined”存在至少一两年了,一直都没修复……解决办法估计只能修改源代码,可以试试将 buffer.jsm 第1678行的let { options } = overlay.activeModules;改成let doc = node.ownerDocument || no ...
harnack 发表于 2015-10-2 12:14
谢谢,出现很囧的一个问题,我找不到 buffer.jsm 的位置,Firefox 和全盘都搜索了
把pentadactyl的xpi安装文件解压缩了后里面有buffer.jsm,改完了重新打包就行了。
听老人说,今生做千件好事,来世方能讨生为猫。
1659# harnack

谢谢猫大,看上去已经完美解决这个问题
作者怎么不更新这两行代码呢
本帖最后由 txlxt 于 2015-10-4 02:12 编辑

1654# harnack
没理解错的话M键并不是Mac的Command键,而是Meta键。该键基本消失了,常常用Alt键代替它,需要使用Meta键的软件有最著名的文本编辑器Emacs。
升级到Firefox 42不能用了,改intall.rdf里的版本号拖到FF里安装,提示无法安装,因似乎已经损坏,请问怎么破?
1662# mrfox

代码在这里: https://github.com/5digits/dactyl
版本号文件: dactyl\pentadactyl\install.rdf
安装cygwin:https://cygwin.com/install.html  自己百度一把吧,我也不熟
代码放这儿:C:\cygwin64\home\Administrator\dactyl\  
运行C:\cygwin64\Cygwin.bat,进入dactyl ,然后执行make xpi -C pentadactyl
运行挺长一段时间,会生成:C:\cygwin64\home\Administrator\dactyl\downloads\pentadactyl-1.2pre.xpi


对Cygwin也不是很熟悉,摸索着这么弄的,附件是我编译好的。

感觉Pentadactyl对fx的启动速度影响很大,包括启动之后打开新窗口的时候
附件: 您所在的用户组无法下载或查看附件
1663# weide

感谢感谢!原来不只是替换压缩包,要编译呀
1664# mrfox

理论上直接替换xpi里边的文件应该也可以的,最近也没改几行代码啊
1665# weide

替换会报错,不知和网上说的签名的问题有无关系
欢迎猫大回来    不要再走了
我也好久没见过猫大了,想起来还是猫大带我翻**W,带我玩pentadactyl的,还教我更高深的东西,感谢猫大!
这贴子也有一千多楼了,找起答案来真是悲伤……。
怎么临时暂停pentadactyl,有时候看图要用JS的快捷键,
网上搜的都说按I或者Insert
这个也没用啊。
1669# Yoona

Ctrl+Z
本帖最后由 babyblue 于 2015-11-28 12:01 编辑

请问:help 不能查看帮助怎么办? 提示这个“Sorry, help file "intro" not found”
火狐版本42,Pentadactyl安装的是本贴1663# 的    pentadactyl-1.2pre.xpi

还有前几天火狐更新到42以后,很容易崩溃。是不是因为安装用的Pentadactyl xpi文件是自己修改过的?  换pentadactyl-1.2pre.xpi 安装以后好一点,也还是偶尔崩溃。大家有这种情况么?

本贴 顶楼 10%处的代码失效了么?这个“实现在页面中快速搜索当前选定词.(google和dict.cn)”
我把后一半w换成v改成了
  1. command! dict -nargs=* tabopen http://dict.cn/<args>
  2. map v :dict
  3. map <silent> V :exe ":dict "+content.getSelection()<CR>
复制代码
有一点效果,可以打开http://dict.cn/ 但是不会自动搜索已经选取的内容,是哪里用错了?
请问dict.js怎么用,我看不到帮助文件,不知道怎么悬停发音,即划即查
1671# babyblue

我这里42也很容易崩溃,不晓得是不是因为我尝鲜装了64位Firefox的关系……

Pentadactyl的帮助是用不成了(至少windows下是如此),暂时用在线帮助吧:http://5digits.org/help/pentadactyl/

你贴的代码测试倒是没有任何问题,试试换个键映射或者排查下和其它自定义命令或脚本有无冲突吧。
听老人说,今生做千件好事,来世方能讨生为猫。
1672# Mozill-A

dict.js设置双击取词是
  1. :se dict-dblclick
复制代码
至于悬停发音,貌似没这功能……
听老人说,今生做千件好事,来世方能讨生为猫。
1673# harnack
多谢猫大回复。
我是win 32位火狐,42的也爱崩溃,退回到41没事了。
那段代码我再排查一下键映射。希望可以正常。
Pentadactyl更新啦,等了好久。
强制禁用这个首选项(高级用户): 你可以在 Firefox 配置编辑页面 (about:config 页面)把 xpinstall.signatures.required 首选项设为 false 来强制禁用附加组件验证的功能。我们不会为手动在配置编辑页面做出的任何修改提供援助,因此请自担风险。

--------------
附件: 您所在的用户组无法下载或查看附件
1676# weide
谢谢大神,可以安装到43,只是:help 也看不到帮助,只能看在线的。是修改过的原因么?
1677# babyblue

我这边为什么可以看呢?
本帖最后由 babyblue 于 2015-12-22 15:21 编辑

1678# weide
那就是我自己这边的问题,新建个空白的试试。

新建的可以看到help,冤枉你的扩展了。马上查找一下原因,更新43.
43下用新版penta,在输入框里有时按ESC一直出不来,不知何故